Friday, April 29, 2011

Teacup and skeinforge 39, where to start.


I've seen more and more people starting to use teacup and they really have no where to start. I had been successfully using SF39 with teacup for a few weeks until one of my Pololu drivers decided to release the magic smoke. I was planning on writing this up after more calibration, but that may be a while.


Arduino 1280

Skeinforge 39 Settings

When I refer to default skeinforge settings I mean the settings that make the boxes return to a grey background, not yellow or teal.

Section Necessity Current settings in my profiles
Bottom required Default skeinforge settings.
Carve n/a Infill in direction of bridge enabled and all settings to default.
Chamber not required Not enabled because I don't have a heated bed.
Clip required Clip over perimater width (ratio) set to 0.35
Others set to default.
Comb required Enabled because it makes for cleaner builds.
Cool not required Not enabled because my extruder oozes to much during cooling (needed for printing small stuff).
Dimension required Enabled and set to "relative extrusion distance" experiment with the setting to work with your extruder.
Export required Activate Export checked
Do not change output
File extension = gcode
Rest are blank.
Fill n/a Default skeinforge values
Activate for filled
Deactivate for shell only
Set Infill solidity ratio to zero for hollow
Fillet not required

Set to Bevel
Corner feed ratio of 1.5
Fillet radius of 0.7
Used to deal with blobby corners but they could be dealt with in other ways.
Home not required I don't use homing.
Hop not required Not enabled because it makes the builds take a long time due to lots of Z movements.
Inset not required No check boxes enabled
Bridge width 1.0
Loop order ascending area
Overlap removal width 0.5
Jitter not required Enabled and set to 2.0
Lash not required Not enabled
Limit not required Not enabled and both set to 0
Multiply not required Not enabled
Oozbane not required Not enabled (use teacups E_startstop_steps)
Outline not required Not enabled (I have a start.gcode that includes an outline purge which is not included so this may be a good idea).
Preface not required Enabled but the start and end gcode files are empty. All check boxes are unchecked except "set to mm".
Raft required Enabled because it is required by  temperature (DO NOT TURN THIS OFF) I have it set to produce no raft but it must still be enabled.
Reversal not required Not enabled
Scale not required Not enabled
Speed required Enabled both speed and flow rate.
Bridge feed rate 1.2
Bridge flow rate 1.0
Duty cycle both set to 0
Feed rate 65
Flow rate 67.5
Orbital feed rate 0.5
Perimeter feed rate 0.7
Perimeter flow rate 0.8
Travel feed rate 200.0.
Splodge not required Not enabled
Stretch not required Enabled
Loop stretch over perimeter width ratio 0.1
All other settings set to default
Temperature required Enabled and possibly set a little to high for PLA due to the thermistor location on my hotend.
Tower not required Not enabled
Unpause not required Not enabled
Widen not required Not enabled
Wipe not required Not enabled

Teacup Configuration

/// used for G0 rapid moves and as a cap for all other feedrates
#define    MAXIMUM_FEEDRATE_X        9900  // 165mm/s
#define    MAXIMUM_FEEDRATE_Y        9900
#define    MAXIMUM_FEEDRATE_Z        300   // 5mm/s
#define    MAXIMUM_FEEDRATE_E        2000  // 33.3mm/s this is set low due to the limitation of my extruder

/// used when searching endstops and as default feedrate
#define    SEARCH_FEEDRATE_X            4800  // 80mm/s
#define    SEARCH_FEEDRATE_Y            4800
#define    SEARCH_FEEDRATE_Z            300
// no SEARCH_FEEDRATE_E, as E can't be searched

/// this is how many steps to suck back the filament by when we stop. set to zero to disable
#define    E_STARTSTOP_STEPS            10


#define    TEMP_HYSTERESIS                5

    Soft axis limits, in mm
    undefine if you don't want to use them

#define    X_MIN            -100.0        // 0 at center of 200
#define    X_MAX            100.0

#define    Y_MIN            -100.0        // 0 at center of 200
#define    Y_MAX            100.0

#define    Z_MIN            0.0             // 0 at platform
#define    Z_MAX            140.0

I printed this Prusa Mendel using these settings.
(Modified to use only one motor for the Z stage)
 My stretch settings are not perfect but close enough that the bearing fit without problem and the other holes needed only a small amount of reaming.

No comments:

Post a Comment